Nothing works cept google

Discuss practical ways rearrange URLs using mod_rewrite.

Nothing works cept google

Postby kris7845 » Mon Mar 10, 2008 12:22 pm

I posted a problem I was having in the beginner's area at but there is too much spam in there. Anyways, I tried a few of the tutorials to see if mod rewrite is working but no matter what I try nothing works, not even the examples given in the FAQ. I went into httpd.conf and verified it was turned on according to the walk through but after modifying my code to display index.html?id=1 in the urls and I use the code in the tut it still does not work. Any pointers on where to look or what to try to resolve the problem?

I am running xampp on a windows pc if that helps any, sorry I dont know more about this stuff to give more info.


Here is the code in my .htaccess file for my latest testing, aside from the addtype it is from the tutorial by richardk (How to change a numeric ID into a name/title. )

AddType application/x-httpd-php .htm
AddType application/x-httpd-php .html

Options +FollowSymLinks

RewriteEngine On

RewriteRule ^index/([0-9]+)-[^/]+\.html$ /index.php?id=$1 [QSA,L]


Sigh, not even the google one works, it gives an error 500


Duh, xampp by default doesn't have mod rewrite installed, I assumed since it was such an important feature with apache that it would have been included. Here is a link to a walkthrough to turn it on in the event anyone ever needs it.
Posts: 3
Joined: Sun Mar 09, 2008 12:34 pm

Return to Friendly URLs with Mod_Rewrite

Who is online

Users browsing this forum: No registered users and 4 guests