I thought I understood how to do this, but ........

CLOSED

I thought I understood how to do this, but ........

Postby skygod12000 » Sat Sep 04, 2010 12:00 am

Hi,

I don't know if there's anyone still watching this forum, but I've gone and caught myself out with Server 500 errors when trying to redirect old URLs to a new URL.

There is a rule that has been in force since the site began (before my involvement) which is as follows :

Code: Select all
RewriteRule ^(.*)/(.*)/(.*) index.php?p=$1&name=$2&id=$3


The old format was

http://domain/developments/properties/, so developments.php has been rename to projects.php and a new string for the name has been used to make the new URL http://domain/projects/Property-Developments-In-City/

I added a new RewriteRule in .htaccess

Code: Select all
RewriteRule ^/developments/properties/$ /projects/Property-Developments-In-City/  [R=301]


and thought things would be fine, but I am simply encountering Server 500 errors.

Whilst the site is not ranked particularly highly in Google, it would be a nuisance to have to wait for the Google cache to expire naturally and then also wait for the new content to be discovered.

Anybody able to assist?

Thx
skygod12000
 
Posts: 8
Joined: Wed Aug 05, 2009 3:13 am

Re: I thought I understood how to do this, but ........

Postby skygod12000 » Sat Sep 04, 2010 3:26 am

It's okay, I have resolved the matter thankfully.

Code: Select all
RewriteRule ^developments/([\x20-\x7E]+)/([\x20-\x7E]+)$       projects/Property-Developments-In-City/$2    [R=301,L]
skygod12000
 
Posts: 8
Joined: Wed Aug 05, 2009 3:13 am


Return to New Threads/Problems

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron